Jump to content


Photo

Hose leaks


  • Please log in to reply
3 replies to this topic

#1 D-Train

D-Train

    Forum Member

  • Members
  • PipPipPip
  • 136 posts
  • Name:Dion
  • Location:Casula
  • Car:LC SL
  • Joined: 03-March 15

Posted 12 March 2019 - 08:08 PM

I’m sure it’s beeen in here but I can’t find it.
In my LC I’ve fitted a black 202. The rad hose from the black 202 water pump to the original LC rad is leaking when full without heat. I bought new pipes from kingswood online and it leaked on the pump side so I tried the old vk one and both sides leaked.
Just using standard clamps. What’s some tips or top notch gear to stop this. If it’s happebing now, it will be waterworks once it’s pressurized .

It’s so
Close and can’t wait to show you guys, after all this forum did 50% of the work with the info passed on over the past 5 years.

Cheer’s gang.

#2 rodomo

rodomo

    To advertise here, call 13TORANA

  • Members
  • PipPipPipPipPipPipPip
  • 16,982 posts
  • Name:R - O - B Dammit!
  • Location:Way out west of Melbourne Awstraylya
  • Joined: 10-December 05

Posted 12 March 2019 - 08:54 PM

Do the clamps up tighter.

#3 D-Train

D-Train

    Forum Member

  • Members
  • PipPipPip
  • 136 posts
  • Name:Dion
  • Location:Casula
  • Car:LC SL
  • Joined: 03-March 15

Posted 13 March 2019 - 11:45 AM

I got my worm drive clamps online so prob Chinese shit.
Repco ones cut the mustard or should I be going spring or t clamp?

#4 grumpy xu1

grumpy xu1

    Forum Fixture

  • Members
  • PipPipPipPipPip
  • 2,044 posts
  • Name:Gary
  • Location:Queensland
  • Car:lj xu1
  • Joined: 01-February 10

Posted 13 March 2019 - 11:02 PM

Just get some tridons, industrial shops have them too.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users